We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 16:24 CDT
Monitoring
We’ve restored platform access after service disruptions from a technology partner. We are monitoring system stability and will evaluate the impact of the outage in the coming days. Thank you for your patience during this outage.
Posted Jun 12, 2025 - 16:23 CDT
Identified
The issue has been identified as a GCP incident across multiple products.
Posted Jun 12, 2025 - 16:18 CDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2025 - 13:48 CDT
Investigating
One of our technology partners is experiencing service disruptions that may impact your ability to log in. Our Engineering team is working hard with our partners to resolve the issue. We apologize for any inconvenience.
Posted Jun 12, 2025 - 13:40 CDT
This incident affected: Health Wallet (Health Wallet Application, Health Wallet API), Health Wallet Manager (Health Wallet Manager Application, Health Wallet Manager API), and Health Wallet Platform (Partner API, Widgets).